SPAMD-SETUP(8) OpenBSD System Manager's Manual SPAMD-SETUP(8)
spamd-setup - parse and load file of spammer addresses
The spamd-setup utility adds blacklists by adding addresses to the pf(4)
table <spamd>, as well as configuring mail rejection messages for the
added list of addresses in spamd(8). The spamd table is used in conjunc-
tion with a pf(4) redirection rule to selectively redirect mail connec-
tions to the spamd(8) daemon.
The options are as follows:
-d Debug mode reports a few pieces of information.
-n Dry-run mode. No data is shipped to pf(4).
Blacklists and whitelists are specified in the configuration file
/etc/spamd.conf and are processed in the order specified in the all tag.
Output is concatenated to build up a table for pf(4). Then the blacklist
addresses are sent to a running spamd(8) along with the message spamd
will give on mail rejection when a matching client connects. The config-
uration port for spamd(8) is found from services(5), by looking for the
named service spamd-cfg.
spamd-setup reads all configuration information from a spamd.conf(5)
ftp(1), pf(4), services(5), spamd.conf(5), spamd(8)
OpenBSD 3.6 February 14, 2003 1