MAILWRAPPER(8) OpenBSD System Manager's Manual MAILWRAPPER(8)
mailwrapper - invoke appropriate MTA software based on configuration file
Special. See below.
At one time, the only Mail Transfer Agent (MTA) software easily available
was sendmail(8). As a result of this, most Mail User Agents (MUAs) such
as mail(1) had the path and calling conventions expected by sendmail(8)
Times have changed, however. On a modern system, the administrator may
wish to use one of several available MTAs.
It would be difficult to modify all MUA software typically available on a
system, so most of the authors of alternative MTAs have written their
front end message submission programs so that they use the same calling
conventions as sendmail(8) and may be put into place instead of
sendmail(8) in /usr/sbin/sendmail.
sendmail(8) also typically has aliases named mailq(8) and newaliases(8)
linked to it. The program knows to behave differently when its argv
is ``mailq'' or ``newaliases'' and behaves appropriately. Typically, re-
placement MTAs provide similar functionality, either through a program
that also switches behavior based on calling name, or through a set of
programs that provide similar functionality.
Although having drop-in replacements for sendmail(8) helps in installing
alternative MTAs, it essentially makes the configuration of the system
depend on hard installing new programs in /usr. This leads to configura-
tion problems for many administrators, since they may wish to install a
new MTA without altering the system provided /usr. (This may be, for ex-
ample, to avoid having upgrade problems when a new version of the system
is installed over the old.) They may also have a shared /usr among sev-
eral machines, and may wish to avoid placing implicit configuration in-
formation in a read-only /usr.
The mailwrapper program is designed to replace /usr/sbin/sendmail and to
invoke an appropriate MTA instead of sendmail(8) based on configuration
information placed in /etc/mailer.conf. This permits the administrator
to configure which MTA is to be invoked on the system at run time.
Configuration for mailwrapper is kept in /etc/mailer.conf.
/usr/sbin/sendmail is typically set up as a symlink to mailwrapper which
is not usually invoked on its own.
mailwrapper will return an error value and print a diagnostic if its con-
figuration file is missing or malformed, or does not contain a mapping
for the name under which mailwrapper was invoked.
mail(1), mailer.conf(5), mailq(8), newaliases(8), sendmail(8)
Perry E. Metzger <perryATpiermont.com>
The entire reason this program exists is a crock. Instead, a command for
how to submit mail should be standardized, and all the "behave different-
ly if invoked with a different name" behavior of things like mailq(8)
should go away.
OpenBSD 3.6 December 16, 1998 1