GETNAME(8) BSD System Manager's Manual GETNAME(8)
getNAME -- get NAME sections from manual source for whatis/apropos data
getNAME [-itvw] path [path ...]
The getNAME utility looks inside manual page sources to find the name of
the page. It can be used to create a table of contents, report the style
of manual, or to create an introductory manual page. By default, getNAME
returns data for use in an apropos(1) database. getNAME is designed to
be called from manual grovelling tools, not to be used directly.
Historically, makewhatis(8) used to use getNAME to get manpage names, but
that's no longer the case.
The following options are available:
-i Print information useful in creating an introduction manual. See
intro(1), intro(2), etc. for examples.
-t Print information useful for creating a table of contents.
-v Complain about incorrectly formatted man pages.
-w Print information whether the manpage uses traditional man
(``OLD''), new mandoc (``NEW''), or some unknown (``UNKNOWN'')
man(1), catman(8), makewhatis(8)
The getNAME command first appeared in 2.0BSD.
It would be nice if getNAME could deal with compressed and/or preformat-
ted manual pages. Looks for .S[Hh] NAME for consistency checking, but
that breaks man pages in other languages.
BSD October 31, 1997 BSD