PANIC(9) BSD Kernel Developer's Manual PANIC(9)
panic -- Bring down system on fatal error
panic(const char *fmt, ...);
The panic() function makes the OpenBSD system terminate. The message fmt
is a printf(9) style format string. The message is printed to the con-
sole and the location pointed to by the global char pointer panicstr is
set to the address of the message text for retrieval from the OS core
If the kernel debugger is installed, control is passed to it. Otherwise,
an attempt is made to save a core dump of the OS to a configured dump
If panic() is called twice (from the disk sync routines, for example) the
system is rebooted without syncing the disks.
The panic() function does not return.
printf(3), boot(9), printf(9)
BSD July 13, 2014 BSD