MICROTIME(9) BSD Kernel Developer's Manual MICROTIME(9)
microtime -- realtime system clock
microtime(struct timeval *tv);
microtime() returns the current value of the system realtime clock in the
structure pointed to by the argument tv. The system realtime clock is
guaranteed to be monotonically increasing at all times. As such, all
calls to microtime() are guaranteed to return a system time greater than
or equal to the system time returned in any previous calls.
settimeofday(2), hardclock(9), hz(9), inittodr(9), time(9)
The implementation of the microtime() function is machine dependent,
hence its location in the source code tree varies from architecture to
Despite the guarantee that the system realtime clock will always be mono-
tonically increasing, it is always possible for the system clock to be
manually reset by the system administrator to any date.
BSD September 14, 1998 BSD