IEEE80211_CRYPTO(9) BSD Kernel Developer's Manual IEEE80211_CRYPTO(9)
ieee80211_crypto_attach, ieee80211_crypto_detach, ieee80211_wep_crypt --
802.11 WEP encryption functions
ieee80211_crypto_attach(struct ifnet *ifp);
ieee80211_crypto_detach(struct ifnet *ifp);
struct mbuf *
ieee80211_wep_crypt(struct ifnet *ifp, struct mbuf *m0, int txflag);
These functions provide software encryption support for 802.11 device
The ieee80211_crypto_attach() function initializes crypto support for the
interface ifp, and sets the initialization vector (IV) for WEP encryption
to a random number derived from a secure PRNG.
The ieee80211_crypto_detach() function frees data structures associated
with crypto support for the interface ifp.
The ieee80211_wep_crypt() function runs the appropriate WEP encryption
algorithm over the 802.11 encapsulated frame held in the mbuf chain m0,
for transmission or reception on the interface ifp. The txflag argument
specifies whether the frame is being received or transmitted. A value of
0 indicates that the frame is being received and should therefore be
decrypted; a non-zero value indicates that the frame is being transmitted
and should be encrypted.
The ieee80211_wep_crypt() function stores its IV in the interface's
embedded struct ieee80211com instance.
The ieee80211 series of functions first appeared in NetBSD 1.5, and were
later ported to FreeBSD 4.6 and OpenBSD 3.6.
This man page was written by Bruce M. Simpson <bms@FreeBSD.org> and
Darron Broad <email@example.com>.
BSD July 17, 2013 BSD