DOMOUNTROOTHOOKS(9) BSD Kernel Developer's Manual DOMOUNTROOTHOOKS(9)
domountroothooks -- run all mountroot hooks
The domountroothooks() function invokes all mountroot hooks established
using the mountroothook_establish(9) function. Mountroot hooks are
called in order, i.e., the mountroot hook established first will be
This function is called from main() with interrupts turned on. It is
called immediately before the system configures its root and swap
devices, but fully after all normal autoconfiguration. This can be used
to let device subsystems needing delayed configuration (e.g., due to very
long initialization times) still provide the root device.
Mountroot hooks are implemented via the more general dohooks(9) API.
BSD December 10, 2014 BSD