CURPROC(9) BSD Kernel Developer's Manual CURPROC(9)
curproc, curcpu -- current process and processor
struct cpu_info *
struct proc *
curcpu() returns a pointer to a cpu_info structure containing information
of the CPU that this thread is running on. curproc() returns a pointer
to the process currently running on this CPU.
BSD May 23, 2002 BSD