BOOT(9) BSD Kernel Developer's Manual BOOT(9)
boot -- halt or reboot the system
The boot() function handles final system shutdown, and either halts or
reboots the system. The exact action to be taken is determined by the
flags passed in howto and by whether or not the system has finished auto-
If the system has finished autoconfiguration, boot() does the following:
1. Sets the boothowto system variable from the howto argument.
2. If this is the first invocation of boot() and the RB_NOSYNC
flag is not set in howto, syncs and unmounts the system disks
by calling vfs_shutdown() and sets the time of day clock by
3. Disables interrupts.
4. If rebooting after a crash (i.e., if RB_DUMP is set in howto,
but RB_HALT is not), saves a system crash dump.
5. Prints a message indicating that the system is about to be
halted or rebooted.
6. If RB_HALT is set in howto, halts the system. Otherwise,
reboots the system.
If the system has not finished autoconfiguration, boot() prints a mes-
sage, and halts the system (unless RB_USERREQ is specified, in which case
the system will be halted if RB_HALT is given, and rebooted otherwise;
see reboot(2) for more details).
BSD December 10, 2014 BSD