BIO_REGISTER(9) BSD Kernel Developer's Manual BIO_REGISTER(9)
bio_register, bio_unregister -- block I/O ioctl tunnelling interface
bio_register(struct device *dev,
int (*bioctl)(struct device *, u_long, caddr_t));
bio_unregister(struct device *dev);
The block I/O ioctl tunnelling interface is used by drivers to register
and unregister ioctl handlers to be accessed via the bio(4) device.
bio_register() is called by the driver represented by dev to register the
bioctl argument as the ioctl handler for itself.
bio_unregister() is called to remove the ioctl handler previously regis-
tered with bio_register() for the device represented by dev.
bio_register() and bio_unregister() can be called during autoconf(9) or
from process context. The bioctl callback is called from process con-
The block I/O ioctl tunnelling interface first appeared in OpenBSD 3.2.
The block I/O ioctl tunnelling interface was written by Niklas Hallqvist
BSD July 17, 2013 BSD