ARC4RANDOM(9) BSD Kernel Developer's Manual ARC4RANDOM(9)
arc4random -- arc4 random number generator
The arc4random() function provides a high quality 32-bit pseudo-random
number very quickly. arc4random() seeds itself on a regular basis from
the kernel strong random number subsystem described in rnd(4). On each
call, an ARC4 generator is used to generate a new result. The
arc4random() function uses the ARC4 cipher key stream generator, which
uses 8*8 8 bit S-Boxes. The S-Boxes can be in about (2**1700) states.
arc4random() fits into a middle ground not covered by other subsystems
such as the strong, slow, and resource expensive random devices described
in rnd(4) versus the fast but poor quality interfaces such as random().
An algorithm called RC4 was designed by RSA Data Security, Inc. It was
considered a trade secret, but not trademarked. Because it was a trade
secret, it obviously could not be patented. A clone of this was posted
anonymously to USENET and confirmed to be equivalent by several sources
who had access to the original cipher. Because of the trade secret situ-
ation, RSA Data Security, Inc. can do nothing about the release of the
ARC4 algorithm. Since RC4 used to be a trade secret, the cipher is now
referred to as ARC4.
These functions first appeared in OpenBSD 2.1.
BSD April 15, 1997 BSD