DELAY(9) BSD Kernel Developer's Manual DELAY(9)
delay, DELAY -- microsecond delay
delay(unsigned int us);
DELAY(unsigned int us);
Wait approximately us microseconds.
The delay is implemented as a machine loop, preventing events other than
interrupt handlers for unmasked interrupts to run. DELAY() is reentrant
(doesn't modify any global kernel or machine state) and is safe to use in
interrupt or process context.
For long delays, tsleep(9) should be considered, however it can only be
called from process context and its resolution is limited by the system
BSD May 23, 2002 BSD