YPXFR(8) OpenBSD System Manager's Manual YPXFR(8)
ypxfr - get a YP map from YP server
ypxfr [-cf] [-d domain] [-h host] [-s domain] [-C tid prog ipadd port]
ypxfr is the utility in YP that transfers maps to the local host.
Since the YP master transfers a map when it has changed, an YP slave
should check for missed maps regularly. This can be done via an entry in
crontab(5). The scripts ypxfr_1perhour, ypxfr_2perday and ypxfr_1perday
could be used for that.
The options are as follows:
-c Don't send a "Clear current map" to local ypserv process. Useful
if ypserv isn't running localy to avoid timeout message.
-f Force map transfer, even if version of master is older than local
Don't use default domain, use the specified domain.
Get map from host instead of the maps master host.
Specify a source domain other than the target domain.
-C tid prog ipadd port
This option is only used by ypserv. This is to open communica-
tion with a yppush on another host.
yp(8), yppush(8), ypserv(8)
Mats O Jansson <mojATstacken.se>
OpenBSD 3.6 August 18, 1994 1