RPC.YPPASSWDD(8) OpenBSD System Manager's Manual RPC.YPPASSWDD(8)
rpc.yppasswdd - YP update password file daemon
rpc.yppasswdd [-d directory] [-noshell] [-nogecos] [-nopw]
[-m arg1 arg2 ...]
rpc.yppasswdd must be running on the YP master server to allow users to
change information in the password file. If the user needs to change his
password this is normally done with a program called yppasswd. This pro-
gram doesn't exist in OpenBSD but is integrated into passwd(1). passwd
will automatically determine which password database should be modified.
To force a change of a YP password when a local one also exists, use
Other user information can be changed with chpass(1).
The options are as follows:
Use the specified directory to get at the password-related files
instead of /etc.
Don't allow changes of the shell field in the passwd file.
Don't allow changes of the gecos field in the passwd file.
-nopw Don't allow changes of the password in the passwd file.
-m arg1 arg2 ...
Pass the specified arguments to make(1) when invoking it in
/var/yp to rebuild the passwd maps.
make(1), securenet(5), ypserv.acl(5), yp(8), ypbind(8)
Mats O Jansson <mojATstacken.se>
OpenBSD 3.6 July 3, 1994 1