YP(8) OpenBSD System Manager's Manual YP(8)
yp - description of the YP subsystem
ypinit [-m] domain
ypinit [-s] server domain
ypset [-h host] [-d domain] server
yppoll [-h host] [-d domain] mapname
ypcat [-kt] [-d domainname] mapname
ypmatch [-kt] [-d domainname] key ... mapname
ypwhich [-d domain] [[-t] -m [mname] | host]
ypserv [-a aclfile] [-d] [-x]
ypxfr [-bcf] [-d domain] [-h host] [-s domain] [-C tid prog ipadd port]
yppush [-d domainname] [-h hostname] [-v] mapname
rpc.yppasswdd [-d directory] [-noshell] [-nogecos] [-nopw]
[-m arg1 arg2 ...]
The YP subsystem allows network management of passwd, group, and hosts
file entries through the functions getpwent(3), getgrent(3) and
gethostbyname(3). A number of other databases can be network-managed as
well, and have their respective functions. YP also provides hooks for
numerous other client programs such as amd(8) and bootparamd(8) to access
distributed and shareable versions of their maps through YP.
ypinit is used to initialize YP as a master or a slave. This creates
various files in /var/yp. By default the YP server will be set up in
backwards compatible mode. To enable ``secure'' mode, the file
/var/yp/Makefile.yp must be edited. This ``secure'' mode is compatible
with OpenBSD and FreeBSD clients.
If set up as a slave, the required databases are automatically copied
from the specified server.
The YP client subsystem is started automatically in /etc/rc if the direc-
tory /var/yp/binding exists. The client subsystem can be turned on and
off by creating or deleting that directory. ypbind(8) will create that
directory if run by hand.
The YP server subsystem is started automatically in /etc/rc if the direc-
tory /var/yp/DOMAINNAME exists. This directory is automatically created
by ypinit(8) (which initializes the machine as a YP server). The YP
server also requires that portmap(8) be running before it is started.
If ypbind cannot find a server, the system behaves the same way as Sun's
code does: it hangs.
/var/yp/Makefile.main Top level YP Makefile
/var/yp/Makefile.yp YP maps Makefile
domainname(1), ypcat(1), ypmatch(1), ypwhich(1), ypclnt(3),
defaultdomain(5), group(5), passwd(5), resolv.conf(5), rpc.yppasswdd(8),
ypbind(8), ypinit(8), yppoll(8), yppush(8), ypserv(8), ypset(8), ypxfr(8)
This free YP subsystem is thought to be compatible with Sun's implementa-
tion. It is, of course, not compatible with NIS+ or any other ``secure''
YP subsystem other than the native one.
The name YP stands for Yellow Pee.
The ypbind, most library components, and userland programs were imple-
mented by Theo de Raadt <deraadtATtheos.com>. The current getpwent(3) im-
plementation was done by Jason Downs <downsjATdownsj.com>. The server
component was implemented by Mats O Jansson <mojATstacken.se>.
OpenBSD 3.6 April 5, 1993 2