WSCONSCTL(8) BSD System Manager's Manual WSCONSCTL(8)
wsconsctl -- get or set wscons state
wsconsctl [-kdm] [-f file] [-n] -a
wsconsctl [-kdm] [-f file] [-n] name ...
wsconsctl [-kdm] [-f file] [-n] -w name=value ...
wsconsctl [-kdm] [-f file] [-n] -w name+=value ...
The wsconsctl command displays or sets various wscons system driver vari-
ables. If a list of variables is present on the command line, then
wsconsctl prints the current value of those variables for the specified
-a is used to specify all variables for the device.
-w wsconsctl attempts to set or modify the specified variables to
the given values. The value can be specified as either an abso-
lute value, by using the '=' symbol or as a relative value, by
using the '+=' symbol. See the EXAMPLES section for more
is used to specify an alternative control device.
-n suppresses the printing of the variable name in the output - only
the value will appear.
-k selects the keyboard portion of the device (this is the default).
-d selects the display portion of the device.
-m selects the mouse portion of the device.
The wsconsctl utility can be used to view and modify aspects of the key-
board, display and mouse, using the standard, machine-independent work-
station console device driver wscons(4).
The keyboard type can be modified, the keyboard bell's pitch, period and
duration can be modified, the typematic value can be changed, and the
keyboard encoding can be modified to switch keys, should the user find a
keyboard's default layout difficult to use. The keyboard types and other
relevant definitions can all be found in the
The mouse types are defined in the /usr/include/dev/wscons/wsconsio.h
The display types, height, width, depth (bits per pixel), color map size,
and color map are defined in the /usr/include/dev/wscons/wsconsio.h file.
There are also definitions relating to video control and cursor control,
which are not applicable to all display types, and to text emulation and
graphics (mapped) modes.
There are currently keyboard encodings for the following countries:
British, Danish, French, German, Italian, Japanese, Norwegian, Spanish,
Swedish, US, US-Dvorak, and user-defined.
/dev/wskbd0 keyboard control device
/dev/wsmouse0 mouse control device
/dev/ttyE0 display control device
The following are just a few examples of wsconsctl and its functionality.
wsconsctl -w encoding=uk
Sets a UK keyboard encoding.
wsconsctl -w map+="keysym Caps_Lock = Control_L"
Modifies the current keyboard encoding so that when the Caps Lock key is
pressed, the same encoding sequence as Left Control is sent. For a full
list of keysyms and keycodes, please refer to the
wsconsctl -w encoding=us.swapctrlcaps
Sets a US keyboard encoding, with the Caps Lock and Left Control keys
swapped. The .swapctrlcaps encoding does not work for all national key-
board encodings. For most purposes, the ability to set the value
returned by the Caps Lock key is enough - see the previous example for
wsconsctl -w bell.pitch=1200
Sets the bell pitch to be 1200, whilst
wsconsctl -w bell.pitch+=200
Adds 200 to the current pitch of the bell.
pckbd(4), wscons(4), wsconscfg(8), wsfontload(8)
The wsconsctl command first appeared in NetBSD 1.4.
BSD December 24, 1998 BSD