VNCONFIG(8) OpenBSD System Manager's Manual VNCONFIG(8)
vnconfig - configure vnode disks for file swapping or pseudo file systems
vnconfig [-c] [-vk] rawdev regular_file
vnconfig -u [-v] rawdev
vnconfig -l [rawdev]
The vnconfig command configures vnode pseudo disk devices. It will asso-
ciate (or disassociate) the special file rawdev with the regular file
regular_file allowing the latter to be accessed as though it were a disk.
Hence a regular file within the filesystem can be used for swapping or
can contain a filesystem that is mounted in the name space. Both tradi-
tional devices, vnd, and the cache-coherent devices, svnd, are configured
If you read the regular file while using svnd, you need to mount the svnd
with the mount option sync to ensure consistency in the buffer cache.
For normal operation this is not necessary.
The options are as follows:
-c Configures the device. If successful, references to rawdev will
access the contents of regular_file. This is the default opera-
-k Associate an encryption key with the device. All data will be
encrypted using the Blowfish cipher before it is written to the
disk. Encryption only works with svnd.
-l List the vnd devices and indicate which ones are in use. If a
specific rawdev is given, then only that one will be described.
-u Unconfigures the device.
-v Print messages to stdout describing actions taken.
If no action option is given, -c is assumed.
Configure the vnode disk svnd0 (all of its partitions become usable):
# vnconfig svnd0 /tmp/diskimage
Unconfigure the same device:
# vnconfig -u svnd0
vnd(4), mount(8), swapon(8), umount(8)
This command should really be named vndconfig.
OpenBSD 3.6 July 8, 1993 1