USERADD(8) BSD System Manager's Manual USERADD(8)
useradd -- add a user to the system
useradd -D [-b base-dir] [-e expiry-time] [-f inactive-time] [-g gid |
name | =uid] [-L login-class] [-k skel-dir] [-r low..high]
useradd [-Smov] [-G secondary-group] [-b base-dir] [-c comment]
[-d home-dir] [-e expiry-time] [-f inactive-time] [-g gid | name
| =uid] [-k skel-dir] [-L login-class] [-p password] [-r
low..high] [-s shell] [-u uid] user
The useradd utility adds a user to the system, creating and populating a
home directory if necessary. Any skeleton files will be provided for the
new user if they exist in the skel-dir directory (see the -k option).
Default values for the base directory, the time of password expiry, the
time of account expiry, primary group, the skeleton directory, the range
from which the uid will be allocated, and default login shell can be pro-
vided in the /etc/usermgmt.conf file, which, if running as root, is cre-
ated using the built-in defaults if it does not exist.
The first form of the command shown above (using the -D option) sets and
displays the defaults for the useradd utility.
-D without any further options, -D will show the current defaults
which will be used by the useradd utility. Together with one of
the options shown for the first version of the command, -D will
set the default to be the new value. See usermgmt.conf(5) for
sets the default base directory. This is the directory to which
the user directory is added, which will be created if the -m
option is specified and no -d option is specified.
sets the default time at which the current password will expire
for new users. It should be entered in the form ``month day
year'', where month is the month name (the first three characters
are sufficient), day is the day of the month, and year is the
year. Time in seconds since the epoch (UTC) is also valid. A
value of 0 can be used to disable this feature.
sets the default time at which new user accounts will expire.
Also see the -e option above.
-g gid | groupname | =uid
sets the default group for new users.
sets the skeleton directory in which to find files with which to
populate new users' home directories.
sets the default login class for new users. See login.conf(5)
for more information on user login classes.
sets the low and high bounds of uid ranges for new users. A new
user can only be created if there are uids which can be assigned
from one of the free ranges.
sets the default login shell for new users.
In the second form of the command, after setting any defaults, and then
reading values from /etc/usermgmt.conf, the following command line
options are processed:
is the secondary group to which the user will be added in the
-S allows samba user names with a trailing dollar sign to be added
to the system.
is the base directory name, in which the user's new home direc-
tory will be created, should the -m option be specified.
is the comment field (also, for historical reasons known as the
GECOS field) which will be added for the user, and typically will
include the user's full name, and, perhaps, contact information
for the user.
is the home directory which will be created and populated for the
user, should the -m option be specified.
sets the time at which the current password will expire for new
users. It should be entered in the form ``month day year'',
where month is the month name (the first three characters are
sufficient), day is the day of the month, and year is the year.
Time in seconds since the epoch (UTC) is also valid. A value of
0 can be used to disable this feature. See passwd(5) for more
sets the time at which new user accounts will expire. Also see
the -e option above.
-g gid | name | =uid
gives the group name or identifier to be used for the new user's
primary group. If this is '=uid', then a uid and gid will be
picked which are both unique and the same, and a line added to
/etc/group to describe the new group.
-k skeleton directory
gives the skeleton directory in which to find files with which to
populate the new user's home directory.
This option sets the login class for the user being created. See
login.conf(5) for more information on user login classes.
-m create a new home directory for the new user.
-o allow the new user to have a uid which is already in use for
specifies an already-encrypted password for the new user. This
password can then be changed by using the chpass(1) utility.
specifies the login shell for the new user.
-u uid specifies a uid for the new user. Boundaries for this value can
be preset for all users by using the range field in the
-v enables verbose mode - explain the commands as they are executed.
Once the information has been verified, useradd uses pwd_mkdb(8) to
update the user database. This is run in the background, and, at very
large sites could take several minutes. Until this update is completed,
the password file is unavailable for other updates and the new informa-
tion is not available to programs.
The useradd utility exits 0 on success, and >0 if an error occurs.
chpass(1), group(5), login.conf(5), passwd(5), usermgmt.conf(5),
pwd_mkdb(8), user(8), userdel(8), usermod(8)
The useradd utility first appeared in NetBSD 1.5. It is based on the
addnerd package by the same author.
The useradd utility was written by Alistair G. Crooks <agcATNetBSD.org>.
BSD January 14, 2004 BSD