UMOUNT(8) OpenBSD System Manager's Manual UMOUNT(8)
umount - unmount file systems
umount [-fv] special | node
umount -a [-fv] [-h host] [-t ufs | lfs | external_type]
The umount command calls the unmount(2) system call to remove a special
device or the remote node (rhost:path) from the file system tree at the
point node. If neither special nor node are provided, the appropriate
information is taken from the fstab(5) file.
The options are as follows:
-a All of the file systems described in fstab(5) are unmounted.
-f The file system is forcibly unmounted. Active special devices
continue to work, but all other files return errors if further
accesses are attempted. The root file system cannot be forcibly
Only filesystems mounted from the specified host will be unmount-
ed. This option implies the -a option and, unless otherwise
specified with the -t option, will only unmount NFS filesystems.
-t ufs | lfs | external type
Is used to indicate the actions should only be taken on filesys-
tems of the specified type. More than one type may be specified
in a comma separated list. The list of filesystem types can be
prefixed with ``no'' to specify the filesystem types for which
action should not be taken. For example, the umount command:
# umount -a -t nfs,mfs
umounts all filesystems of the type NFS and MFS.
-v Verbose, additional information is printed out as each file sys-
tem is unmounted.
/etc/fstab file system table
unmount(2), fstab(5), mount(8)
A umount command appeared in Version 3 AT&T UNIX.
OpenBSD 3.6 February 20, 1994 1