UMOUNT(8) BSD System Manager's Manual UMOUNT(8)
umount -- unmount file systems
umount [-fv] special | node | fsid
umount -a | -A [-F fstab] [-fv] [-h host] [-t type]
The umount utility calls the unmount(2) system call to remove a file sys-
tem from the file system tree. The file system can be specified by its
special device or remote node (rhost:path), the path to the mount point
node or by the file system ID fsid as reported by ``mount -v''.
The options are as follows:
-a All the file systems described in fstab(5) are unmounted.
-A All the currently mounted file systems except the root are
Specify the fstab file to use.
-f The file system is forcibly unmounted. Active special devices
continue to work, but all other files return errors if further
accesses are attempted. The root file system cannot be forcibly
Only file systems mounted from the specified host will be
unmounted. This option implies the -A option and, unless other-
wise specified with the -t option, will only unmount NFS file
Is used to indicate the actions should only be taken on file sys-
tems of the specified type. More than one type may be specified
in a comma separated list. The list of file system types can be
prefixed with ``no'' to specify the file system types for which
action should not be taken. For example, the umount command:
umount -a -t nfs,nullfs
unmounts all file systems of the type NFS and NULLFS that are
listed in the fstab(5) file.
-v Verbose, additional information is printed out as each file sys-
tem is unmounted.
PATH_FSTAB If the environment variable PATH_FSTAB is set, all operations
are performed against the specified file. PATH_FSTAB will
not be honored if the process environment or memory address
space is considered ``tainted''. (See issetugid(2) for more
/etc/fstab file system table
unmount(2), fstab(5), mount(8)
A umount utility appeared in Version 6 AT&T UNIX.
BSD July 18, 2003 BSD