TUNEFS(8) BSD System Manager's Manual TUNEFS(8)
tunefs -- tune up an existing file system
tunefs [-A] [-a enable | disable] [-e maxbpg] [-f avgfilesize]
[-L volname] [-l enable | disable] [-m minfree]
[-n enable | disable] [-o space | time] [-p] [-s avgfpdir] special
The tunefs utility is designed to change the dynamic parameters of a file
system which affect the layout policies. The tunefs utility cannot be
run on an active file system. To change an active file system, it must
be downgraded to read-only or unmounted.
The parameters which are to be changed are indicated by the flags given
-A The file system has several backups of the super-block. Specify-
ing this option will cause all backups to be modified as well as
the primary super-block. This is potentially dangerous - use
-a enable | disable
Turn on/off the administrative ACL enable flag.
Indicate the maximum number of blocks any single file can allo-
cate out of a cylinder group before it is forced to begin allo-
cating blocks from another cylinder group. Typically this value
is set to about one quarter of the total blocks in a cylinder
group. The intent is to prevent any single file from using up
all the blocks in a single cylinder group, thus degrading access
times for all files subsequently allocated in that cylinder
group. The effect of this limit is to cause big files to do long
seeks more frequently than if they were allowed to allocate all
the blocks in a cylinder group before seeking elsewhere. For
file systems with exclusively large files, this parameter should
be set higher.
Specify the expected average file size.
Add/modify an optional file system volume label.
-l enable | disable
Turn on/off MAC multilabel flag.
Specify the percentage of space held back from normal users; the
minimum free space threshold. The default value used is 8%.
Note that lowering the threshold can adversely affect perfor-
o Settings of 5% and less force space optimization to always be
used which will greatly increase the overhead for file
o The file system's ability to avoid fragmentation will be
reduced when the total free space, including the reserve,
drops below 15%. As free space approaches zero, throughput
can degrade by up to a factor of three over the performance
obtained at a 10% threshold.
If the value is raised above the current usage level, users will
be unable to allocate files until enough files have been deleted
to get under the higher threshold.
-n enable | disable
Turn on/off soft updates.
-o space | time
The file system can either try to minimize the time spent allo-
cating blocks, or it can attempt to minimize the space fragmenta-
tion on the disk. Optimization for space has much higher over-
head for file writes. The kernel normally changes the preference
automatically as the percent fragmentation changes on the file
-p Show a summary of what the current tunable settings are on the
selected file system. More detailed information can be obtained
from the dumpfs(8) utility.
Specify the expected number of files per directory.
At least one of the above flags is required.
/etc/fstab read this to determine the device file for a specified mount
fs(5), dumpfs(8), newfs(8)
M. McKusick, W. Joy, S. Leffler, and R. Fabry, "A Fast File System for
UNIX", ACM Transactions on Computer Systems 2, 3, pp 181-197, August
1984, (reprinted in the BSD System Manager's Manual, SMM:5).
This utility should work on active file systems.
You can tune a file system, but you can't tune a fish.
The tunefs utility appeared in 4.2BSD.
BSD May 18, 2002 BSD