TRACEROUTE6(8) BSD System Manager's Manual TRACEROUTE6(8)
traceroute6 -- print the route IPv6 packets will take to a network node
traceroute6 [-dIlnrv] [-f firsthop] [-g gateway] [-m hoplimit] [-p port]
[-q probes] [-s src] [-w waittime] target [datalen]
The traceroute6 utility uses the IPv6 protocol hop limit field to elicit
an ICMPv6 TIME_EXCEEDED response from each gateway along the path to some
The only mandatory parameter is the destination host name or IPv6
address. The default probe datagram carries 12 bytes of payload, in
addition to the IPv6 header. The size of the payload can be specified by
giving a length (in bytes) after the destination host name.
Other options are:
-d Debug mode.
Specify how many hops to skip in trace.
Specify intermediate gateway (traceroute6 uses routing header).
-I Use ICMP6 ECHO instead of UDP datagrams.
-l Print both host hostnames and numeric addresses. Normally
traceroute6 prints only hostnames if
Specify maximum hoplimit, up to 255. The default is 30 hops. -n
is not specified, and only numeric addresses if -n is specified.
-n Do not resolve numeric address to hostname.
Set UDP port number to port.
Set the number of probe per hop count to probes.
-s src Src specifies the source IPv6 address to be used.
-v Be verbose.
Specify the delay time between probes.
This program prints the route to the given destination and the round-trip
time to each gateway, in the same manner as traceroute.
Here is a list of possible annotations after the round-trip time for each
!N Destination Unreachable - No Route to Host.
!P Destination Unreachable - Administratively Prohibited.
!S Destination Unreachable - Not a Neighbour.
!A Destination Unreachable - Address Unreachable.
! This is printed if the hop limit is <= 1 on a port unreach-
able message. This means that the packet got to the desti-
nation, but that the reply had a hop limit that was just
large enough to allow it to get back to the source of the
traceroute6. This was more interesting in the IPv4 case,
where some IP stack bugs could be identified by this behav-
The traceroute6 utility will exit with 0 on success, and non-zero on
ping(8), ping6(8), traceroute(8)
The traceroute6 utility first appeared in WIDE hydrangea IPv6 protocol
BSD May 17, 1998 BSD