TELNETLOGIN(8) BSD System Manager's Manual TELNETLOGIN(8)
telnetlogin -- login wrapper for telnetd
telnetlogin [-h host] [-p] [-f username] [username]
telnetlogin is a setuid wrapper that runs login(1). It is meant to be
invoked by telnetd(8); the idea is to remove the necessity of running
telnetd as root.
telnetlogin should be installed mode 4750, user root, group telnetd.
Then, telnetd may be run from /etc/inetd.conf as user ``nobody'', group
``telnetd'', and with the option -L path-to-telnetlogin.
telnetlogin accepts only the subset of options to login(1) shown above,
in the order listed. This is the order telnetd 8 normally provides them
in. telnetlogin also does sanity checks on the environment variables
TERM, and REMOTEHOST. It also insists that the standard input, output,
and error streams are open on a terminal, and that it is the process
group leader of the foreground process of that terminal. After checking
all of these conditions, checking the values of the above environment
variables for reasonable values, resetting signal handlers, and so forth,
it execs login.
login(1), inetd.conf(5), inetd(8), telnetd(8)
THIS IS PRESENTLY EXPERIMENTAL CODE; USE WITH CAUTION.
telnetlogin was written during the development of NetKit 0.17.
Linux NetKit (0.17) April 12, 2000 Linux NetKit (0.17)