SYSLOGD(8) BSD System Manager's Manual SYSLOGD(8)
syslogd - log systems messages
syslogd [-f config_file] [-m mark_interval] [-p log_socket]
Syslogd reads and logs messages to the system console, log files, other
machines and/or users as specified by its configuration file. The op-
tions are as follows:
-f Specify the pathname of an alternate configuration file; the de-
fault is /etc/syslog.conf.
-m Select the number of minutes between ``mark'' messages; the de-
fault is 20 minutes.
-p Specify the pathname of an alternate log socket; the default is
Syslogd reads its configuration file when it starts up and whenever it
receives a hangup signal. For information on the format of the configu-
ration file, see syslog.conf(5).
Syslogd reads messages from the UNIX domain socket /dev/log, from an In-
ternet domain socket specified in /etc/services, and from the special de-
vice /dev/klog (to read kernel messages).
Syslogd creates the file /var/run/syslog.pid, and stores its process id
there. This can be used to kill or reconfigure syslogd.
The message sent to syslogd should consist of a single line. The message
can contain a priority code, which should be a preceding decimal number
in angle braces, for example, `<5.>' This priority code should map into
the priorities defined in the include file <sys/syslog.h>.
/etc/syslog.conf The configuration file.
/var/run/syslog.pid The process id of current syslogd.
/dev/log Name of the UNIX domain datagram log socket.
/dev/klog The kernel log device.
logger(1), syslog(3), services(5), syslog.conf(5)
The syslogd command appeared in 4.3BSD.
4.2 Berkeley Distribution June 6, 1993 1