SWAPON(8) BSD System Manager's Manual SWAPON(8)
swapon - specify additional device for paging and swapping
swapon special_file ...
Swapon is used to specify additional devices on which paging and swapping
are to take place. The system begins by swapping and paging on only a
single device so that only one disk is required at bootstrap time. Calls
to swapon normally occur in the system multi-user initialization file
/etc/rc making all swap devices available, so that the paging and swap-
ping activity is interleaved across several devices.
Normally, the first form is used:
-a All devices marked as ``sw'' swap devices in /etc/fstab are made
The second form gives individual block devices as given in the system
swap configuration table. The call makes only this space available to
the system for swap allocation.
swapon(2), fstab(8) init(8) rc(8)
/dev/[ru][pk]?b standard paging devices
/etc/fstab ascii filesystem description table
There is no way to stop paging and swapping on a device. It is therefore
not possible to make use of devices which may be dismounted during system
The swapon command appeared in 4.0BSD.
4th Berkeley Distribution June 5, 1993 1