SWAPCTL(8) OpenBSD System Manager's Manual SWAPCTL(8)
swapctl, swapon - system swap management tool
swapctl -A [-p priority] [-t blk|noblk]
swapctl -a [-p priority] path
swapctl -c -p priority path
swapctl -d path
swapctl -l | -s [-k]
swapon -a | path
The swapctl program adds, removes, lists and prioritizes swap devices and
files for the system. The swapon program acts the same as the swapctl
program, as if called with the -a option, except if swapon itself is
called with -a, in which case swapon acts as swapctl with the -A option.
Note: The initial swap device (root disk, partition b) is handled auto-
matically by the kernel and does not need to be added to /etc/fstab or
added via swapctl. It will show up as "swap_device" in the output dis-
played with the -l flag.
The options are as follows:
-A This option causes swapctl to read the /etc/fstab file for de-
vices and files with an ``sw'' type, and adds all these entries
as swap devices. If no swap devices are configured, swapctl will
exit with an error code.
-a The -a option requires that a path also be in the argument list.
The path is added to the kernel's list of swap devices using the
swapctl(2) system call. When using the swapon form of this com-
mand, the -a option is treated the same as the -A option, for
-c The -c option changes the priority of the listed swap device or
The -d option removes the listed path from the kernel's list of
swap devices or files.
-l The -l option lists the current swap devices and files, and their
-s The -s option displays a single line summary of current swap
The -p option sets the priority of swap devices or files to the
priority argument. This works with the -a, -c and -l options.
-k The -k option uses 1024 byte blocks instead of the default 512
This flag modifies the function of the -A option. The -t option
allows the type of device to add to be specified. An argument of
blk causes all block devices in /etc/fstab to be added. An argu-
ment of noblk causes all non-block devices in /etc/fstab to be
added. This option is useful in early system startup, where
swapping may be needed before all file systems are available,
such as during disk checks of large file systems.
When parsing the /etc/fstab file for swap devices, lines such as the fol-
lowing specify additional swap devices:
/dev/sd1b none swap sw 0 0
Additional flags include:
priority=N This option sets the priority of the specified swap de-
vice to N. The highest priority is 0, second priority is
nfsmntpt=/path This option is useful for swapping to NFS files. It
specifies the local mount point to mount an NFS filesys-
tem. Typically, once this mount has succeeded, the file
to be used for swapping on will be available under this
point mount. For example:
server:/export/swap/client none swap sw,nfsmntpt=/swap
Local and remote swap files cannot be configured until the file systems
they reside on are mounted read/write. The system startup scripts need
to fsck(8) all local file systems before this can happen. This process
requires substantial amounts of memory on some systems. If one config-
ures no local block swap devices on a machine that has local file systems
to check and rely only on swap files, the machine will have no swap space
at all during system fsck(8) and may run out of real memory, causing fsck
to abnormally exit and startup scripts to fail.
swapctl(2), fstab(5), mount_nfs(8), vnconfig(8)
The swapctl program was originally developed in NetBSD 1.3. It was port-
ed to OpenBSD 2.6 by Tobias Weingartner. The original swapon program,
provided for backwards compatibility, appeared in 4.0BSD.
The swapctl program was written by Matthew R. Green <mrgATeterna.au>.
OpenBSD 3.6 June 12, 1997 2