STICKY(8) OpenBSD System Manager's Manual STICKY(8)
sticky - sticky text and append-only directories
A special file mode, called the sticky bit (mode S_ISVTX), is used to in-
dicate special treatment for files and directories. See chmod(2) or the
file /usr/include/sys/stat.h for an explanation of file modes.
Historically, an executable shareable file which had the sticky bit set
was not immediately discarded from swap space after execution. The ker-
nel hoarded the text segment of the file for future reuse, thus avoiding
having to reload the program. This is no longer true on modern systems;
the current virtual memory system keeps track of recently used executa-
bles, making the sticky bit for files redundant. The sticky bit can
still be set on files, but without any effect.
Only the superuser can set the sticky bit on a file, though the owner of
the file may clear the sticky bit.
A directory with the `sticky bit' set places restrictions on file dele-
tion: a file in a sticky directory may only be removed or renamed by a
user if the user has write permission for the directory and the user is
the owner of the file, the owner of the directory, or the superuser.
This feature is usefully applied to directories such as /tmp which must
be publicly writable but should deny users the license to arbitrarily
delete or rename each others' files.
Any user may create a sticky directory. See chmod(1) for details about
modifying file modes.
A sticky command appeared in Version 32V AT&T UNIX.
Neither open(2) nor mkdir(2) will create a file with the sticky bit set.
OpenBSD 3.6 June 5, 1993 1