STICKY(8) BSD System Manager's Manual STICKY(8)
sticky - sticky text and append-only directories
A special file mode, called the sticky bit (mode S_ISVTX), is used to in-
dicate special treatment for shareable executable files and directories.
See chmod(2) or the file /usr/include/sys/stat.h for an explanation of
STICKY TEXT EXECUTABLE FILES
An executable shareable file whose sticky bit is set will not be immedi-
ately discarded from swap space after execution. The kernel will hoard
the text segment of the file for future reuse and avoid having to reload
the program. Shareable text segments are normally placed in a least-
frequently-used cache after use, and thus the `sticky bit' has little ef-
fect on commonly-used text images.
Sharable executable files are created with the -n and -z options of the
Only the super-user can set the sticky bit on a sharable executable file.
A directory whose `sticky bit' is set becomes an append-only directory,
or, more accurately, a directory in which the deletion of files is re-
stricted. A file in a sticky directory may only be removed or renamed by
a user if the user has write permission for the directory and the user is
the owner of the file, the owner of the directory, or the super-user.
This feature is usefully applied to directories such as /tmp which must
be publicly writable but should deny users the license to arbitrarily
delete or rename each others' files.
Any user may create a sticky directory. See chmod(1) for details about
modifying file modes.
Since the text areas of sticky text executables are stashed in the swap
area, abuse of the feature can cause a system to run out of swap.
Neither open(2) nor mkdir(2) will create a file with the sticky bit set.
A sticky command appeared in Version 32V AT&T UNIX.
4th Berkeley Distribution June 5, 1993 1