SLIPLOGIN(8) OpenBSD System Manager's Manual SLIPLOGIN(8)
sliplogin - attach a serial line network interface
sliplogin is used to turn the terminal line on standard input into a Se-
rial Line IP (SLIP) link to a remote host. To do this, the program
searches the file /etc/sliphome/slip.hosts for an entry matching
loginname (which defaults to the current login name if omitted). If a
matching entry is found, the line is configured appropriately for slip
(8-bit transparent I/O) and converted to SLIP line discipline. Then a
shell script is invoked to initialize the slip interface with the appro-
priate local and remote IP address, netmask, etc.
The usual initialization script is /etc/sliphome/slip.login but, if par-
ticular hosts need special initialization, the file
/etc/sliphome/slip.login.loginname will be executed instead if it exists.
The script is invoked with the parameters
slipunit The unit number of the slip interface assigned to this line.
e.g., 0 for sl0.
speed The speed of the line.
args The arguments from the /etc/sliphome/slip.hosts entry, in order
starting with loginname.
Only the superuser may attach a network interface. The interface is au-
tomatically detached when the other end hangs up or the sliplogin process
dies. If the kernel slip module has been configured for it, all routes
through that interface will also disappear at the same time. If there is
other processing a site would like done on hangup, the file
/etc/sliphome/slip.logout or /etc/sliphome/slip.logout.loginname is exe-
cuted if it exists. It is given the same arguments as the login script.
Format of /etc/sliphome/slip.hosts
Comments (lines starting with a `#') and blank lines are ignored. Other
lines must start with a loginname but the remaining arguments can be
whatever is appropriate for the slip.login file that will be executed for
that name. Arguments are separated by whitespace and follow normal sh(1)
quoting conventions (however, loginname cannot be quoted). Usually,
lines have the form
loginname local-address remote-address netmask opt-args
where local-address and remote-address are the IP host names or addresses
of the local and remote ends of the slip line and netmask is the appro-
priate IP netmask. These arguments are passed directly to ifconfig(8).
Opt-args are optional arguments used to configure the line.
The normal use of sliplogin is to create a /etc/passwd entry for each le-
gal, remote slip site with sliplogin as the shell for that entry. e.g.,
Sfoo:ikhuy6:2010:1:slip line to foo:/tmp:/usr/sbin/sliplogin
(Our convention is to name the account used by remote host hostname as
Shostname.) Then an entry is added to slip.hosts that looks like:
Sfoo `hostname` foo netmask
where `hostname` will be evaluated by sh(1) to the local host name and
netmask is the local host IP netmask.
Note that sliplogin must be setuid to root and is only executable by
users in group network. To permit use, place a user into that group.
Users in that group are of course also able to use sliplogin to place
terminal lines in an unusable state and/or deny access to legitimate
users of a remote slip line.
sliplogin logs various information to the system log daemon, syslogd(8),
with a facility code of daemon. The messages are listed here, grouped by
ioctl (TCGETS): reason
A TCGETS ioctl() to get the line parameters failed.
ioctl (TCSETS): reason
A TCSETS ioctl() to set the line parameters failed.
The /etc/sliphome/slip.hosts file could not be opened.
access denied for user
No entry for user was found in /etc/sliphome/slip.hosts.
attaching slip unit unit for loginname
SLIP unit unit was successfully attached.
The sliplogin command is currently in beta test.
OpenBSD 3.6 August 5, 1991 2