SLATTACH(8) BSD System Manager's Manual SLATTACH(8)
slattach, slip -- attach serial lines as network interfaces
slattach [-Hhlmn] [-s baudrate] [-t ldisc] ttyname
slattach is used to assign a tty line to a network interface, and to
define the network source and destination addresses. The following oper-
ands are supported by slattach:
-H Turn on DTR/CTS flow control. By default, no flow control
-h Turn on RTS/CTS flow control. By default, no flow control
-l Turn on the CLOCAL flag, making it possible to run SLIP on
a cable without modem control signals (e.g. DTR, DSR, DCD).
-m Maintain modem control signals after closing the line.
Specifically, this disables HUPCL.
-n Don't detach from invoking tty.
-s baudrate Specifies the speed of the connection. If not specified,
the default of 9600 is used.
-t ldisc Specifies the line discipline to use for the tty. Sup-
ported line disciplines are ``slip'' (creates a sl(4)
instance) and ``strip'' (creates a strip(4) instance). If
this option is not specified, the default is ``slip''.
ttyname Specifies the name of the tty device. ttyname should be a
string of the form 'ttyXX', or '/dev/ttyXX'.
In addition, the following flags to ifconfig(8) control various proper-
ties of a SLIP link:
link0 Turn on Van Jacobsen header compression.
-link0 Turn off header compression.
link1 Don't pass through ICMP packets.
-link1 Do pass through ICMP packets.
link2 If a packet with a compressed header is received, automati-
cally enable compression of outgoing packets.
-link2 Don't auto-enable compression.
Only the super-user may attach a network interface.
To detach the interface, use ``ifconfig interface-name down'' after
killing off the slattach process. Interface-name is the name that is
shown by netstat(1).
slattach -s 4800 /dev/tty01
Messages indicating that the specified interface does not exist, the
requested address is unknown, or that the user is not privileged but
tried to alter an interface's configuration.
netstat(1), daemon(3), netintro(4), sl(4), strip(4), ifconfig(8), rc(8)
The slattach command appeared in 4.3BSD.
BSD September 3, 1999 BSD