SETEXTATTR(8) OpenBSD System Manager's Manual SETEXTATTR(8)
setextattr - set a named extended attribute
setextattr attrnamespace attrname filename attrvalue
setextattr is a user tool to set a named extended attribute on a file or
directory to the provided string. The attrnamespace argument should be
the namespace of the attribute to retrieve: legal values are "user" and
"system". The attrname argument should be the name of the attribute,
filename the name of the file or directory to set the attribute for, and
attrvalue a string to store in the attribute. setextattr will store the
string in the file's attribute. In order for setextattr to succeed, the
attribute service must be available on the file system, and appropriate
privilege may be required.
# setextattr system md5 /bsd `md5 < /bsd`
Set the ``md5'' extended attribute on the file /bsd to the string con-
taining the output of ``md5 < /bsd''.
extattr(2), extattr(3), extattrctl(8), getextattr(8), extattr(9)
Extended attribute support was developed as part of the TrustedBSD Pro-
ject. It was developed to support security extensions requiring addi-
tional labels to be associated with each file or directory.
Robert N M Watson
setextattr can only be used to set attributes to strings.
OpenBSD 3.6 March 30, 2000 1