SENDMAIL(8) OpenBSD System Manager's Manual SENDMAIL(8)
sendmail - an electronic mail transport agent
sendmail [flags] [address ...] [-v]
Sendmail sends a message to one or more recipients, routing the message
over whatever networks are necessary. Sendmail does internetwork for-
warding as necessary to deliver the message to the correct place.
Sendmail is not intended as a user interface routine; other programs pro-
vide user-friendly front ends; sendmail is used only to deliver pre-for-
With no flags, sendmail reads its standard input up to an end-of-file or
a line consisting only of a single dot and sends a copy of the message
found there to all of the addresses listed. It determines the network(s)
to use based on the syntax and contents of the addresses.
Local addresses are looked up in a file and aliased appropriately.
Aliasing can be prevented by preceding the address with a backslash. Be-
ginning with 8.10, the sender is included in any alias expansions, e.g.,
if `john' sends to `group', and `group' includes `john' in the expansion,
then the letter will also be delivered to `john'.
-Ac Use submit.cf even if the operation mode does not indicate an
initial mail submission.
-Am Use sendmail.cf even if the operation mode indicates an ini-
tial mail submission.
-Btype Set the body type to type. Current legal values are 7BIT or
-ba Go into ARPANET mode. All input lines must end with a CR-LF,
and all messages will be generated with a CR-LF at the end.
Also, the ``From:'' and ``Sender:'' fields are examined for
the name of the sender.
-bd Run as a daemon. Sendmail will fork and run in the back-
ground listening on socket 25 for incoming SMTP connections.
By default, Sendmail will also listen on socket 587 for RFC
2476 message submission. This is normally run from /etc/rc.
-bD Same as -bd except runs in foreground.
-bh Print the persistent host status database.
-bH Purge expired entries from the persistent host status
-bi Initialize the alias database.
-bm Deliver mail in the usual way (default).
-bp Print a listing of the queue(s).
-bP Print number of entries in the queue(s); only available with
shared memory support.
-bs Use the SMTP protocol as described in RFC 821 on standard in-
put and output. This flag implies all the operations of the
-ba flag that are compatible with SMTP.
-bt Run in address test mode. This mode reads addresses and
shows the steps in parsing; it is used for debugging configu-
-bv Verify names only - do not try to collect or deliver a mes-
sage. Verify mode is normally used for validating users or
-Cfile Use alternate configuration file. Sendmail gives up any en-
hanced (set-user-ID or set-group-ID) privileges if an alter-
nate configuration file is specified.
-D logfile Send debugging output to the indicated log file instead of
Set the debugging flag for category to level. The category
is either an integer or a name specifying the topic; the
level is an integer specifying the level of debugging output
desired. Higher levels generally mean more output. More
than one flag may be specified by separating flags with com-
mas. A list of numeric debugging categories can be found in
the TRACEFLAGS file in the sendmail source distribution.
The option -d0.1 prints the version of sendmail and the op-
tions it was compiled with.
Most other categories are only useful with, and documented
in, sendmail 's source code.
-Ffullname Set the full name of the sender.
-fname Sets the name of the ``from'' person (i.e., the envelope
sender of the mail). This address may also be used in the
From: header if that header is missing during initial submis-
sion. The envelope sender address is used as the recipient
for delivery status notifications and may also appear in a
Return-Path: header. -f should only be used by ``trusted''
users (normally root, daemon, and network) or if the person
you are trying to become is the same as the person you are.
Otherwise, an X-Authentication-Warning header will be added
to the message.
-G Relay (gateway) submission of a message, e.g., when rmail
-hN Set the hop count to N. The hop count is incremented every
time the mail is processed. When it reaches a limit, the
mail is returned with an error message, the victim of an
aliasing loop. If not specified, ``Received:'' lines in the
message are counted.
-i Ignore dots alone on lines by themselves in incoming mes-
sages. This should be set if you are reading data from a
-L tag Set the identifier used in syslog messages to the supplied
-N dsn Set delivery status notification conditions to dsn, which can
be `never' for no notifications or a comma separated list of
the values `failure' to be notified if delivery failed,
`delay' to be notified if delivery is delayed, and `success'
to be notified when the message is successfully delivered.
-n Don't do aliasing.
Set option option to the specified value. This form uses
long names. See below for more details.
-ox value Set option x to the specified value. This form uses single
character names only. The short names are not described in
this manual page; see the Sendmail Installation and Operation
Guide for details.
-pprotocol Set the name of the protocol used to receive the message.
This can be a simple protocol name such as ``UUCP'' or a pro-
tocol and hostname, such as ``UUCP:ucbvax''.
-q[time] Process saved messages in the queue at given intervals. If
time is omitted, process the queue once. time is given as a
tagged number, with `s' being seconds, `m' being minutes (de-
fault), `h' being hours, `d' being days, and `w' being weeks.
For example, `-q1h30m' or `-q90m' would both set the timeout
to one hour thirty minutes. By default, sendmail will run in
the background. This option can be used safely with -bd.
-qp[time] Similar to -qtime, except that instead of periodically fork-
ing a child to process the queue, sendmail forks a single
persistent child for each queue that alternates between pro-
cessing the queue and sleeping. The sleep time is given as
the argument; it defaults to 1 second. The process will al-
ways sleep at least 5 seconds if the queue was empty in the
previous queue run.
-qf Process saved messages in the queue once and do not fork(),
but run in the foreground.
-qG name Process jobs in queue group called name only.
Limit processed jobs to those containing substr as a sub-
string of the queue ID or not when ! is specified.
Limit processed jobs to quarantined jobs containing substr as
a substring of the quarantine reason or not when ! is speci-
Limit processed jobs to those containing substr as a sub-
string of one of the recipients or not when ! is specified.
Limit processed jobs to those containing substr as a sub-
string of the sender or not when ! is specified.
Quarantine a normal queue items with the given reason or un-
quarantine quarantined queue items if no reason is given.
This should only be used with some sort of item matching us-
ing as described above.
-R return Set the amount of the message to be returned if the message
bounces. The return parameter can be `full' to return the
entire message or `hdrs' to return only the headers. In the
latter case also local bounces return only the headers.
-rname An alternate and obsolete form of the -f flag.
-t Read message for recipients. To:, Cc:, and Bcc: lines will
be scanned for recipient addresses. The Bcc: line will be
deleted before transmission.
-V envid Set the original envelope id. This is propagated across SMTP
to servers that support DSNs and is returned in DSN-compliant
-v Go into verbose mode. Alias expansions will be announced,
-X logfile Log all traffic in and out of mailers in the indicated log
file. This should only be used as a last resort for debug-
ging mailer bugs. It will log a lot of data very quickly.
-- Stop processing command flags and use the rest of the argu-
ments as addresses.
There are also a number of processing options that may be set. Normally
these will only be used by a system administrator. Options may be set
either on the command line using the -o flag (for short names), the -O
flag (for long names), or in the configuration file. This is a partial
list limited to those options that are likely to be useful on the command
line and only shows the long names; for a complete list (and details),
consult the Sendmail Installation and Operation Guide. The options are:
Use alternate alias file.
On mailers that are considered ``expensive'' to connect to,
don't initiate immediate connection. This requires queueing.
Checkpoint the queue file after every N successful deliveries
(default 10). This avoids excessive duplicate deliveries
when sending to long mailing lists interrupted by system
Set the delivery mode to x. Delivery modes are `i' for in-
teractive (synchronous) delivery, `b' for background (asyn-
chronous) delivery, `q' for queue only - i.e., actual deliv-
ery is done the next time the queue is run, and `d' for de-
ferred - the same as `q' except that database lookups for
maps which have set the -D option (default for the host map)
Set error processing to mode x. Valid modes are `m' to mail
back the error message, `w' to ``write'' back the error mes-
sage (or mail it back if the sender is not logged in), `p' to
print the errors on the terminal (default), `q' to throw away
error messages (only exit status is returned), and `e' to do
special processing for the BerkNet. If the text of the mes-
sage is not mailed back by modes `m' or `w' and if the sender
is local to this machine, a copy of the message is appended
to the file dead.letter in the sender's home directory.
Save UNIX-style From lines at the front of messages.
The maximum number of times a message is allowed to ``hop''
before we decide it is in a loop.
IgnoreDots Do not take dots on a line by themselves as a message termi-
Send error messages in MIME format. If not set, the DSN (De-
livery Status Notification) SMTP extension is disabled.
Set connection cache timeout.
Set connection cache size.
LogLevel=n The log level.
Don't send to ``me'' (the sender) if I am in an alias expan-
Validate the right hand side of aliases during a
If set, this message may have old style headers. If not set,
this message is guaranteed to have new style headers (i.e.,
commas instead of spaces between addresses). If set, an
adaptive algorithm is used that will correctly determine the
header format in most cases.
Select the directory in which to queue messages.
Save statistics in the named file.
Set the timeout on undelivered messages in the queue to the
specified time. After delivery has failed (e.g., because of
a host being down) for this amount of time, failed messages
will be returned to the sender. The default is five days.
If set, a user database is consulted to get forwarding infor-
mation. You can consider this an adjunct to the aliasing
mechanism, except that the database is intended to be dis-
tributed; aliases are local to a particular host. This may
not be available if your sendmail does not have the USERDB
option compiled in.
Fork each job during queue runs. May be convenient on memo-
Strip incoming messages to seven bits.
Set the handling of eight bit input to seven bit destinations
to mode: m (mimefy) will convert to seven-bit MIME format, p
(pass) will pass it as eight bits (but violates protocols),
and s (strict) will bounce the message.
Sets how long a job must ferment in the queue between at-
tempts to send it.
Sets the default character set used to label 8-bit data that
is not otherwise labelled.
If opening a connection fails, sleep for sleeptime seconds
and try again. Useful on dial-on-demand sites.
Set the behaviour when there are no recipient headers (To:,
Cc: or Bcc:) in the message to action: none leaves the mes-
sage unchanged, add-to adds a To: header with the envelope
recipients, add-apparently-to adds an Apparently-To: header
with the envelope recipients, add-bcc adds an empty Bcc:
header, and add-to-undisclosed adds a header reading `To:
Sets the maximum number of children that an incoming SMTP
daemon will allow to spawn at any time to N.
Sets the maximum number of connections per second to the SMTP
port to N.
In aliases, the first character of a name may be a vertical bar to cause
interpretation of the rest of the name as a command to pipe the mail to.
It may be necessary to quote the name to keep sendmail from suppressing
the blanks from between arguments. For example, a common alias is:
msgs: "|/usr/bin/msgs -s"
Aliases may also have the syntax ``:include:filename'' to ask sendmail to
read the named file for a list of recipients. For example, an alias such
would read /usr/local/lib/poets.list for the list of addresses making up
Sendmail returns an exit status describing what it did. The codes are
defined in <sysexits.h>:
EX_OK Successful completion on all addresses.
EX_NOUSER User name not recognized.
EX_UNAVAILABLE Catchall meaning necessary resources were not
EX_SYNTAX Syntax error in address.
EX_SOFTWARE Internal software error, including bad arguments.
EX_OSERR Temporary operating system error, such as ``cannot
EX_NOHOST Host name not recognized.
EX_TEMPFAIL Message could not be sent immediately, but was
If invoked as newaliases, sendmail will rebuild the alias database. If
invoked as mailq, sendmail will print the contents of the mail queue. If
invoked as hoststat, sendmail will print the persistent host status
database. If invoked as purgestat, sendmail will purge expired entries
from the persistent host status database.
sendmail often gets blamed for many problems that are actually the result
of other problems, such as overly permissive modes on directories. For
this reason, sendmail checks the modes on system directories and files to
determine if they can be trusted. Although these checks can be turned
off and your system security reduced by setting the DontBlameSendmail op-
tion, the permission problems should be fixed. For more information,
Except for the file /etc/mail/sendmail.cf itself the following pathnames
are all specified in /etc/mail/sendmail.cf. Thus, these values are only
/etc/mail/aliases raw data for alias names
/etc/mail/aliases.db data base of alias names
/etc/mail/sendmail.cf configuration file
/etc/mail/sendmail.hf help file
/var/log/sendmail.st collected statistics
/var/spool/mqueue/* temp files
mail(1), syslog(3), aliases(5), mailer.conf(5), mailaddr(7),
mail.local(8), mailq(8), newaliases(8), rc(8), rmail(8)
DARPA Internet Request For Comments RFC 819, RFC 821, RFC 822.
"Sendmail Installation and Operation Guide",
"Sendmail - An Internetwork Mail Router",
"Filtering Mail with Sendmail",
The sendmail command appeared in 4.2BSD.
OpenBSD 3.6 December 1, 2003 7