SDPCONTROL(8) BSD System Manager's Manual SDPCONTROL(8)
spdcontrol -- SDP query utility
spdcontrol -a address command [parameters ...]
spdcontrol -l [-c path] command [parameters ...]
The spdcontrol utility attempts to query specified Service Discovery Pro-
tocol (SDP) server. Remote SDP servers are identified by their address.
Connection to the local SDP server is made via control socket. The
spdcontrol utility will use Service Search Attribute Request and will
print results to the standard output and error messages to the standard
The options are as follows:
Connect to the remote device with the specified address. The
address can be specified as BD_ADDR or name. If name was speci-
fied then the spdcontrol utility will attempt to resolve the name
Specify path to the control socket. The default path is
-h Display usage message and exit.
-l Query the local SDP server via the control socket.
One of the supported commands (see below). Special command help
can be used to obtain the list of all supported commands. To get
more information about specific command use help command.
One or more optional space separated command parameters.
The currently supported node commands in spdcontrol are:
The spdcontrol utility only implements client side functionality.
The spdcontrol utility only requests the following attributes from the
1. Service Record Handle
2. Service Class ID List
3. Protocol Descriptor List
4. Bluetooth Profile Descriptor List
The spdcontrol utility exits 0 on success, and >0 if an error occurs.
Maksim Yevmenkin <m_evmenkinATyahoo.com>
BSD September 7, 2003 BSD