RTQUERY(8) OpenBSD System Manager's Manual RTQUERY(8)
rtquery - query routing daemons for their routing tables
rtquery [-np1] [-w timeout] [-r addr] host ...
rtquery is used to query a network routing daemon, routed(8) or gated,
for its routing table by sending a request or poll command. The routing
information in any routing ``response'' packets returned is displayed nu-
merically and symbolically.
rtquery by default uses the request command. When the -p option is spec-
ified, rtquery uses the poll command, an undocumented extension to the
RIP protocol supported by gated. When querying gated, the poll command
is preferred over the request command because the response is not subject
to Split Horizon and/or Poisoned Reverse, and because some versions of
gated do not answer the Request command. Routed does not answer the Poll
command, but recognizes Requests coming from rtquery and so answers com-
rtquery is also used to turn tracing on or off in routed(8).
The options are as follows:
-n Normally network and host numbers are displayed both symbolically
and numerically. The -n option displays only the numeric network
and host numbers.
-p Uses the poll command to request full routing information from
gated. This is an undocumented extension RIP protocol supported
only by gated.
-1 Query using RIP version 1 instead of RIP version 2.
Changes the delay for an answer from each host. By default, each
host is given 15 seconds to respond.
Ask about the route to destination addr.
-t op Change tracing, where op is one of the following. Requests from
processes not running with UID 0 or on distant networks are gen-
erally ignored by the daemon except for a message in the system
Turn tracing on into the specified file. That file
must usually have been specified when the daemon was
started or be the same as a fixed name, often
more Increases the debugging level.
off Turns off tracing.
dump Dumps the daemon's routing table to the current trace-
RFC 1058 - Routing Information Protocol, RIPv1
RFC 1723 - Routing Information Protocol, RIPv2
OpenBSD 3.6 June 1, 1996 2