RPC.YPPASSWDD(8) BSD System Manager's Manual RPC.YPPASSWDD(8)
rpc.yppasswdd -- YP update password file daemon
rpc.yppasswdd [-d directory] [-noshell] [-nogecos] [-nopw]
[-m arg1 [arg2 ...]]
rpc.yppasswdd must be running on the YP master server to allow users to
change information in the password file.
The options are as follows:
-d directory Change the root directory of the password file from
``/'' to directory. It is important to create the
binary database files (pwd.db and spwd.db) when
using this switch or the password change will fail.
The databases need to be created only once with the
pwd_mkdb -d directory
-noshell Don't allow changes of the shell field in the
-nogecos Don't allow changes of the gecos field in the
-nopw Don't allow changes of the password in the passwd
-m arg1 [arg2 ...]
Additional arguments to pass to make in /var/yp.
chpass(1), passwd(1), hosts_access(5), yp(8), ypbind(8), ypserv(8)
Mats O Jansson <mojATstacken.se>
BSD August 22, 2003 BSD