REVNETGROUP(8) BSD System Manager's Manual REVNETGROUP(8)
revnetgroup -- generate reverse netgroup data
revnetgroup -u -h [-f netgroup_file]
revnetgroup processes the contents of a file in netgroup(5) format into
what is called reverse netgroup form. That is, where the original file
shows netgroup memberships in terms of which members reside in a particu-
lar group, the reverse netgroup format specifies what groups are associ-
ated with a particular member. This information is used to generate the
netgroup.byuser and netgroup.byhosts YP maps. These reverse netgroup maps
are used to help speed up netgroup lookups, particularly for the
innetgr() library function.
For example, the standard /etc/netgroup file may list a netgroup and a
list of its members. Here, the netgroup is considered the key and the
member names are the data. By contrast, the reverse netgroup.byusers
database lists each unique member as the key and the netgroups to which
the members belong become the data. Seperate databases are created to
hold information pertaining to users and hosts; this allows netgroup
username lookups and netgroup hostname lookups to be performed using
By constructing these reverse netgroup databases (and the corresponding
YP maps) in advance, the getnetgrent(3) library functions are spared from
having to work out the dependencies themselves on the fly. This is impor-
tant on networks with large numbers of users and hosts, since it can take
a considerable amount of time to process very large netgroup databases.
The revnetgroup command prints its results on the standard output. It is
usually called only by /var/yp/<<domain>>/Makefile when rebuilding the YP
The revnetgroup command supports the following options:
-u Generate netgroup.byuser output; only username information in the
original netgroup file is processed.
-h Generate netgroup.byhost output; only hostname information in the
original netgroup file is processed. (Note at least one of the -u
or -h flags must be specified.)
The revnetgroup command uses /etc/netgroup as its default input
file. The -f flag allows the user to specify an alternate input
file. Specifying ``-'' as the input file causes revnetgroup to read
from the standard input.
/var/yp/<domain>Makefile The Makefile that calls makedbm and
revnetgroup to build the YP databases.
/etc/netgroup The default netgroup database file.
This file is most often found only on
the YP master server.
getnetgrent(3), yp(8), netgroup(5), makedbm(8)
Bill Paul <wpaulATctr.edu>
BSD October 24, 1995 BSD