RENICE(8) OpenBSD System Manager's Manual RENICE(8)
renice - alter priority of running processes
renice priority [[-p] pid ...] [[-g] pgrp ...] [[-u] user ...]
renice alters the scheduling priority (an integer) of one or more running
processes. The following who parameters (pid, pgrp and user) are inter-
preted as process IDs, process group IDs, or user names. reniceing a
process group causes all processes in the process group to have their
scheduling priority altered. reniceing a user causes all processes owned
by the user to have their scheduling priority altered. By default, the
processes to be affected are specified by their process IDs.
The options are as follows:
-g Force who parameters to be interpreted as process group IDs.
-u Force the who parameters to be interpreted as user names.
-p Resets the who interpretation to be (the default) process IDs.
# renice +1 987 -u daemon root -p 32
would change the priority of process IDs 987 and 32, and all processes
owned by users daemon and root.
Users other than the superuser may only alter the priority of processes
they own, and can only monotonically increase their ``nice value'' within
the range 0 to PRIO_MAX (20). (This prevents overriding administrative
fiats.) The superuser may alter the priority of any process and set the
priority to any value in the range PRIO_MIN (-20) to PRIO_MAX. Useful
priorities are: 20 (the affected processes will run only when nothing
else in the system wants to), 0 (the ``base'' scheduling priority), any-
thing negative (to make things go very fast).
/etc/passwd for mapping user names to user IDs
nice(1), getpriority(2), setpriority(2)
The renice command appeared in 4.0BSD.
Non-superusers cannot increase scheduling priorities of their own pro-
cesses, even if they were the ones that decreased the priorities in the
OpenBSD 3.6 June 9, 1993 1