RC.CONF(8) OpenBSD System Manager's Manual RC.CONF(8)
rc.conf - system daemon configuration database
This file contains a series of Bourne-shell syntax assignments that are
used to configure the system daemons. It is not read by the kernel, but
is sourced by various other files in the /etc/rc.* series in order to
set shell variables used therein to control the behaviour of the scripts.
It is advisable to leave the /etc/rc.conf file untouched, and instead
create and edit a new /etc/rc.conf.local file. Variables set in this
file will override variables previously set in /etc/rc.conf.
There are three sections in this file. The first is used to turn fea-
tures on or off. For example, whether the system runs the routed daemon
is determined by the line in this section
routed=NO # for normal use: "-q"
If this line is edited to contain some valid routed daemon command-line
flags, such as
routed="-q" # for normal use: "-q"
then the routed daemon will be started with those options.
The second section contains some other programs that can either be run or
not, but that don't need options. They can be set to YES or NO. For ex-
ample, the line
prevents the NFS server daemons from starting. To run NFS, just change
this line's value from NO to YES, and also make whatever changes are
needed for the server to have something to do (set up the exports(5) file
The third section contains values that parameterize servers started by
one of the first two sections, and are ignored if the corresponding serv-
er is not running. For example, if nfs_server, is enabled, then the line
provides command-line arguments for the NFS server.
This particular line instructs nfsd(8) to start four copies of the serv-
er. On a busy file server, 8 (or more) copies are recommended.
and the detailed documentation given for each server that is configurable
in this fashion.
The rc.conf file first appeared in OpenBSD 2.2.
OpenBSD 3.6 January 5, 1998 1