RC(8) BSD System Manager's Manual RC(8)
rc - command script for auto-reboot and daemons
Rc is the command script which controls the automatic reboot and rc.local
is the script holding commands which are pertinent only to a specific
When an automatic reboot is in progress, rc is invoked with the argument
autoboot. The first portion of rc runs an fsck(8) with option -p to
``preen'' all the disks of minor inconsistencies resulting from the last
system shutdown and to check for serious inconsistencies caused by hard-
ware or software failure. If this auto-check and repair succeeds, then
the second part of rc is run.
The second part of rc, which is run after an auto-reboot succeeds and al-
so if rc is invoked when a single user shell terminates (see init(8)),
starts all the daemons on the system, preserves editor files and clears
the scratch directory /tmp.
Rc.local is executed immediately before any other commands after a suc-
cessful fsck. Normally, the first commands placed in the rc.local file
define the machine's name, using hostname(1), and save any possible core
image that might have been generated as a result of a system crash, with
savecore(8). The latter command is included in the rc.local file because
the directory in which core dumps are saved is usually site specific.
Following tradition, the startup files rc and rc.local reside in /etc.
init(8), reboot(8), savecore(8)
The rc command appeared in 4.0BSD.
4th Berkeley Distribution December 11, 1993 1