RAYCONTROL(8) BSD System Manager's Manual RAYCONTROL(8)
raycontrol -- configure Raytheon Raylink/Webgear Aviator devices
raycontrol -i iface [-o]
raycontrol -i iface -t tx rate
raycontrol -i iface -n network name
raycontrol -i iface -c ap status
raycontrol -i iface -p port type
raycontrol -i iface -m mac address
raycontrol -i iface -d max data length
raycontrol -i iface -r RTS threshold
raycontrol -i iface -f hopset
raycontrol -i iface -P 0|1
raycontrol -i iface -S max_sleep_duration
raycontrol -i iface -Z zero signal cache
raycontrol -i iface -C display signal cache
The raycontrol utility controls the operation of Raylink/Webgear wireless
networking devices via the ray(4) driver. Most of the parameters that
can be changed relate to the IEEE 802.11 protocol which the card imple-
ments. This includes the station name, whether the station is operating
in ad-hoc or infrastructure mode, and the network name of a service set
to join - the BSS in ad-hoc mode or ESS if infrastructure mode is
enabled. The raycontrol utility can also be used to view the current
settings of these parameters and to dump out the values of the card's
The iface argument given to raycontrol should be the logical interface
name associated with the Raylink/Webgear device (ray0, ray1, ...).
The options are as follows:
-i iface [-o]
Display the current settings of the specified Raylink/Webgear
interface. This retrieves the current card settings from the
driver and prints them out. The results from this command
are a snapshot of the card settings. Using the additional -o
flag will cause raycontrol to print out the statistics coun-
ters instead of the card settings.
-i iface -t tx rate
Set the transmit rate of the specified interface. The NICs
support a maximum transmit rate of 2Mbps. The following ta-
ble shows the legal transmit rate settings and the corre-
sponding transmit speeds:
TX rate NIC speed
1 Very Low (0.5Mbps)
2 Low (1Mbps)
3 Medium (1.5Mbps)
4 High (2Mbps)
The version 4 firmware may ignore this setting. Note, that
the IEEE 802.11 standard only allows 1Mbps or 2Mbps opera-
tion, and that the generally accepted reading of the IEEE
802.11 standard is that 2Mbps is only allowed in infrastruc-
-i iface -n network name
Set the name of the service set that this station wishes to
join. The network name can be any text string up to 32 char-
acters in length. The default name is the string "NET-
WORK_NAME" which should allow the station to connect to the
default Webgear ad-hoc network.
-i iface -p port type
Set the port type for a specified interface. The legal val-
ues for port type are 0 (ad-hoc mode) and 1 (infrastructure
mode). In ad-hoc mode, the station can communicate directly
with any other stations within direct radio range (provided
that they are also operating in ad-hoc mode). In infrastruc-
ture mode, hosts must associate with a service set controlled
by an access point, that relays traffic between end stations.
The default setting is 0 (ad-hoc mode).
When in ad-hoc mode the station will create a BSS with the
network name specified by the -n option if it cannot find an
existing network of that name on the currently configured
hopset (see the -f option).
-i iface -m mac address
Set the station address for the specified interface. The mac
address is specified as a series of six hexadecimal values
separated by colons, e.g.: 00:60:1d:12:34:56. This programs
the new address into the card and updates the interface as
-i iface -d max_data_length
Set the maximum transmit frame size for a specified inter-
face. The max data length can be any number from 350 to 2304
or -1 to disable fragmentation. The default is -1.
-i iface -r RTS threshold
Set the RTS/CTS threshold for a given interface. This con-
trols the number of bytes used for the RTS/CTS handshake
boundary. The RTS threshold can be any value between -1 and
2047. The default is -1 (disable).
-i iface -f hopset
Set the radio hopset of a given interface. The hopset should
be specified as a country code as shown in the table below.
The hopset varies both the number of RF channels and their
frequencies and is dependent on radio regulations specified
by regional authorities.
Hopset ID Country
9 Japan Test
Whilst the card can be programmed to work with any hopset it
makes sense to use the hopset for your own region to avoid
interference from and interfering with other users of the RF
spectrum (in places like France this is the military).
Note that all stations must be set to the same hopset in
order to communicate.
-i iface -P 0|1
Enable or disable power management on a given interface.
Enabling power management uses an alternating sleep/wake pro-
tocol to help conserve power on mobile stations, at the cost
of some increased receive latency. Power management is off
Note that power management requires the cooperation of an
access point in order to function; it is not functional in
ad-hoc mode. Legal values for this parameter are 0 (off) and
-i iface -S max_sleep_interval
Specify the sleep interval to use when power management is
enabled. The max_sleep_interval is specified in millisec-
onds. The default is 100.
-i iface -Z
Clear the signal strength cache maintained internally by the
-i iface -C
Display the cached signal strength information maintained by
the ray(4) driver. The driver retains information about sig-
nal strength and noise level for packets received from dif-
ferent hosts. For infrastructure networks the cache stores
the signal strength of the access point.
The driver also uses the cache to pick the best antenna when
The raycontrol utility first appeared in FreeBSD 4.0.
The raycontrol utility was written by Duncan Barclay
<dmlbATragnet.uk> and based on the wicontrol utility by Bill Paul
The -m, -P, -S and -Z options aren't implemented yet. No access point
was available for testing against.
Not tested with Version 5 firmware.
Hopset changing may not work with version 4 firmware.
The -W option is un-documented on purpose.
BSD March 21, 2000 BSD