RARPD(8) OpenBSD System Manager's Manual RARPD(8)
rarpd - reverse ARP daemon
rarpd [-adflt] [interface]
rarpd services Reverse ARP requests on the Ethernet connected to
interface. Upon receiving a request, rarpd maps the target hardware ad-
dress to an IP address via its name, which must be present in both the
ethers(5) and hosts(5) databases. If a host does not exist in both
databases, the translation cannot proceed and a reply will not be sent.
In normal operation, rarpd forks a copy of itself and runs in the back-
ground. Anomalies and errors are reported via syslog(3).
The options are as follows:
-a Listen on all the Ethernets attached to the system. If -a is
omitted, an interface must be specified.
-d Run in debug mode, with all the output to stderr. This option
implies the -f option.
-f Run in the foreground.
-l Log all requests to syslog(3).
-t Only honour a requests if if the server (i.e., the host that
rarpd is running on) can "boot" the target; that is, if a file or
directory called /tftpboot/ipaddr exists, where ipaddr is the
target IP address expressed in uppercase hexidecimal (only the
first 8 characters of filenames are checked).
/etc/ethers Ethernet host name database
/etc/hosts host name database
/var/run/rarpd.pid process id of rarpd
Finlayson, R., Mann, T., Mogul, J.C., and Theimer, M., A Reverse Address
Resolution Protocol, RFC 903.
Craig Leres (leresATee.gov) and Steven McCanne (mccanneATee.gov).
Lawrence Berkeley Laboratory, University of California, Berkeley, CA.
OpenBSD 3.6 October 26, 1990 1