PSTAT(8) BSD System Manager's Manual PSTAT(8)
pstat, swapinfo -- display system data structures
pstat [-Tfknst] [-M core [-N system]]
swapinfo [-k] [-M core [-N system]]
The pstat utility displays open file entry, swap space utilization, ter-
minal state, and vnode data structures.
If invoked as swapinfo the -s option is implied, and only the -k option
If the -M option is not specified, information is obtained from the cur-
rently running kernel via the sysctl(3) interface. Otherwise, informa-
tion is read from the specified core file, using the name list from the
specified kernel image (or from the default image).
The following options are available:
-n Print devices out by major/minor instead of name.
-k Print sizes in kilobytes, regardless of the setting of the
BLOCKSIZE environment variable.
-T Print the number of used and free slots in several system tables.
This is useful for checking to see how large system tables have
become if the system is under heavy load.
-f Print the open file table with these headings:
LOC The core location of this table entry.
TYPE The type of object the file table entry points to.
FLG Miscellaneous state variables encoded thus:
R open for reading
W open for writing
A open for appending
I signal pgrp when data ready
CNT Number of processes that know this open file.
MSG Number of messages outstanding for this file.
DATA The location of the vnode table entry or socket structure
for this file.
OFFSET The file offset (see lseek(2)).
-s Print information about swap space usage on all the swap areas
compiled into the kernel. The first column is the device name of
the partition. The next column is the total space available in
the partition. The Used column indicates the total blocks used
so far; the Available column indicates how much space is remain-
ing on each partition. The Capacity reports the percentage of
If more than one partition is configured into the system, totals
for all of the statistics will be reported in the final line of
-t Print table for terminals with these headings:
RAW Number of characters in raw input queue.
CAN Number of characters in canonicalized input queue.
OUT Number of characters in output queue.
MODE See tty(4).
ADDR Physical device address.
DEL Number of delimiters (newlines) in canonicalized input
COL Calculated column position of terminal.
STATE Miscellaneous state variables encoded thus:
T delay timeout in progress
W waiting for open to complete
F outq has been flushed during DMA
C carrier is on
c connection open
B busy doing output
A process is waiting for space in output queue
a process is waiting for output to complete
X open for exclusive use
S output stopped (ixon flow control)
m output stopped (carrier flow control)
o output stopped (CTS flow control)
d output stopped (DSR flow control)
K input stopped
Y send SIGIO for input events
D state for lowercase '\' work
E within a '\.../' for PRTRUB
L next character is literal
P retyping suspended input (PENDIN)
N counting tab width, ignore FLUSHO
l block mode input routine in use
s i/o being snooped
Z connection lost
SESS Kernel address of the session structure.
PGID Process group for which this is controlling terminal.
DISC Line discipline; 'term' for TTYDISC or 'ntty' for NTTY-
DISC or 'tab' for TABLDISC or 'slip' for SLIPDISC or
'ppp' for PPPDISC.
-M Extract values associated with the name list from the specified
-N If -M is also specified, extract the name list from the specified
system instead of the default, which is the kernel image the sys-
tem has booted from.
ps(1), systat(1), stat(2), fs(5), iostat(8), vmstat(8)
K. Thompson, UNIX Implementation.
Does not understand NFS swap servers.
The pstat utility appeared in 4.0BSD.
BSD May 23, 2002 BSD