PCICTL(8) BSD System Manager's Manual PCICTL(8)
pcictl -- a program to manipulate the PCI bus
pcictl pcibus command [arg [...]]
pcictl allows a user or system administrator to access various resources
on a PCI bus.
The following commands are available:
list [-b bus] [-d device] [-f function]
List the devices in the PCI domain. The bus, device, and function num-
bers may be specified by flags. If the bus is not specified, it defaults
to the bus number of the PCI bus specified on the command line. Any
other locator not specified defaults to a wildcard, or may be explicitly
wildcarded by specifying ``any''.
dump [-b bus] -d device [-f function]
Dump the PCI configuration space for the specified device located at the
specified bus, device, and function. If the bus is not specified, it
defaults to the bus number of the PCI bus specified on the command line.
If the function is not specified, it defaults to 0.
/dev/pci* - PCI bus device nodes
The pcictl command first appeared in NetBSD 1.6.
BSD September 12, 2001 BSD