PCCARDC(8) BSD System Manager's Manual PCCARDC(8)
pccardc -- PC-CARD (PCMCIA) management and monitoring tool
pccardc subcommand [arg ...]
The pccardc utility controls PC-CARD slots and configures and displays
information about PCMCIA cards. It understands the following subcom-
beep Set beep type
dumpcis Print card CIS(s)
dumpcisfile Print card CIS(s) from files
enabler Device driver enabler
help Print command summary
pccardmem Allocate memory for pccard driver
power Power on/off slots and leaves them disabled
rdattr Read attribute memory
rdmap Read pcic mappings
rdreg Read pcic register
wrattr Write byte to attribute memory
wrreg Write pcic register
1. beep beep_mode
Specifies the sound made upon card insertion or removal. This sub-
command corresponds to pccard_beep in rc.conf(5). Allowed values
for beep_mode are:
0 silent mode
1 simple beep mode
2 melody mode
2. dumpcis [slot]
Displays CIS (Card Information Structure) tuple in EEPROM of a PC-
CARD card. Slot specifies which slot to read. When no option is
supplied, it displays the CIS of all of the available cards.
3. dumpcisfile file ...
Displays CIS(s) in the same format as dumpcis, but does so using one
or more files as the input CIS data instead of physical PC-CARD
4. enabler slot driver [-m card addr size] [-a iobase] [-i irq]
This is a "point enabler" which can be used to set parameters manu-
ally to enable a card when pccardd(8) cannot allocate drivers to a
PC-CARD card properly. Specify a PC-CARD slot in slot and a device
name (such as "ed0" or "sio2") in driver, along with some or all of
the following options:
-m card addr size
maps the shared-memory window of the card to host address.
card is the starting address of shared-memory (hex) in the
card's address space, addr is the address (hex) to map the
memory to in the computer's address space, and size is the
size of memory window (kb).
iobase specifies the port a number to be mapped to the I/O
-i irq irq specifies the IRQ (decimal from 1 to 15) the card will
use for interrupts.
enabler 0 ed0 -m 2000 d4000 16 -a 300 -i 3
assigns the card in slot zero to the first NE2000 ethernet card
driver at port 0x300 and IRQ 3, mapping the 16KB memory region at
0x2000 in the card to 0xd4000.
This allows use of some unrecognized cards with broken CIS tuples,
and is also useful for testing a card that has not yet reported.
However, beware that it frequently cannot recognize new cards prop-
Prints help for pccardc.
6. pccardmem addr
Specifies the host address using PC-CARD controller(PCIC) will use
to map cards to. Because the PCIC needs a contiguous 16KB memory,
and most machines have other ROMs or devices at other places in the
ISA I/O memory address range, generally you can only use the follow-
ing four addresses:
0xd0000 0xd0000-0xd3fff (default)
You can use "DEFAULT" instead of 0xd0000. This subcommand corre-
sponds to pccard_mem in rc.conf(5).
7. power slot power_mode
Changes the state of the power supply of the card in the specified
0 Turn off a power supply. If a card becomes unstable when it
is removed at activate state, this can force it into inac-
tive state first and remove it safely. The slot will remain
disabled until you eject the card with the system running or
reenable the card with another pccardc power power command.
The slot will even remain disabled when you suspend and
resume the computer.
1 Turn on a power supply and set it into active state (the
system treats the card as if it was just inserted).
8. rdattr slot offs length
Prints a hex dump length bytes long of the EEPROM of the card in
slot slot starting at offs. All parameters are in hex.
9. rdmap [slot]
Displays where the four memory windows and two I/O windows of a PC-
CARD slot are mapped to on the host. If slot is not supplied, it
displays the information for all of slots in the system.
10. rdreg [slot]
Displays the 64 registers of the card in slot (all slots by
11. wrattr slot offs value
Writes a single byte to the card's EEPROM at an offset address from
the top specified in offs (hex), with a value specified in value
(hex). This is preserved after the card is removed.
12. wrreg slot reg value
Writes a register of a PC-CARD. Specify a PC-CARD slot number in
slot, a register number in reg (hex) and a value in value (hex).
/etc/rc.conf configuration file
The original version was written by Andrew McRae <andrewATmega.au>.
Tatsumi Hosokawa <hosokawaATmt.jp> fixed bugs and added some
features. This man page was written by Toshihiko ARAI
Be careful when using enabler and wrattr. Misuse can make the system
unstable or damage the card.
BSD November 14, 1998 BSD