PAM_FTPUSERS(8) BSD System Manager's Manual PAM_FTPUSERS(8)
pam_ftpusers -- ftpusers PAM module
[service-name] module-type control-flag pam_ftpusers [options]
The ftpusers service module for PAM, pam_ftpusers provides functionality
for only one PAM category: account management. In terms of the
module-type parameter, this is the ``account'' feature.
Ftpusers Account Management Module
The ftpusers account management component (pam_sm_acct_mgmt()), succeeds
if and only if the user is listed in /etc/ftpusers.
The following options may be passed to the authentication module:
debug syslog(3) debugging information at LOG_DEBUG level.
no_warn suppress warning messages to the user. These messages include
reasons why the user's authentication attempt was declined.
disallow reverse the semantics; pam_ftpusers will succeed if and only if
the user is not listed in /etc/ftpusers.
ftpusers(5), pam.conf(5), pam(8)
The pam_ftpusers module and this manual page were developed for the
FreeBSD Project by ThinkSec AS and NAI Labs, the Security Research Divi-
sion of Network Associates, Inc. under DARPA/SPAWAR contract
N66001-01-C-8035 (``CBOSS''), as part of the DARPA CHATS research pro-
BSD April 17, 2002 BSD