NTPD(8) OpenBSD System Manager's Manual NTPD(8)
ntpd - Network Time Protocol daemon
ntpd [-d] [-f file]
The ntpd daemon synchronizes the local clock to one or more remote NTP
servers, and can also act as an NTP server itself, redistributing the lo-
cal time. It implements the Simple Network Time Protocol version 4, as
described in RFC 2030, and the Network Time Protocol version 3, as de-
scribed in RFC 1305.
ntpd is usually started at boot time, and can be enabled by setting the
following in /etc/rc.conf.local:
See rc(8) and rc.conf(8) for more information on the boot process and en-
When ntpd starts up, it reads settings from a configuration file, typi-
The options are as follows:
-d Do not daemonize. If this option is specified, ntpd will run
in the foreground and log to stderr.
-f file Use file as the configuration file, instead of the default
/etc/ntpd.conf default ntpd configuration file
date(1), ntpd.conf(5), rdate(8), timed(8)
Network Time Protocol (Version 3), RFC 1305, March 1992.
Simple Network Time Protocol (SNTP) Version 4, RFC 2030, October 1996.
The ntpd program first appeared in OpenBSD 3.6.
OpenBSD 3.6 July 9, 2004 1