NFSD(8) OpenBSD System Manager's Manual NFSD(8)
nfsd - remote NFS server
nfsd [-rtu] [-n num_servers]
nfsd runs on a server machine to service NFS requests from client ma-
chines. At least one nfsd must be running for a machine to operate as a
Unless otherwise specified, four servers for UDP transport are started.
The options are as follows:
Specifies how many servers to create (max 20).
-r Register the NFS service with portmap(8) without creating any
servers. This option can be used along with the -u or -t options
to re-register NFS if the portmap server is restarted.
-t Serve TCP NFS clients.
-u Serve UDP NFS clients.
For example, ``nfsd -u -t -n 6'' serves UDP and TCP transports using six
A server should run enough daemons to handle the maximum level of concur-
rency from its clients, typically four to six.
nfsd listens for service requests at the port indicated in the NFS server
specification; see Network File System Protocol Specification, RFC 1094
and NFS: Network File System Version 3 Protocol Specification.
The nfsd utility exits 0 on success or >0 if an error occurred.
nfsstat(1), nfssvc(2), mountd(8), portmap(8)
The nfsd utility first appeared in 4.4BSD.
OpenBSD 3.6 March 29, 1995 1