NEXTBOOT(8) BSD System Manager's Manual NEXTBOOT(8)
nextboot -- specify an alternate kernel and boot flags for the next
nextboot [-f] [-o options] -k kernel
The nextboot utility allows specifying an alternate kernel and/or boot
flags for the next time the machine is booted. Once the loader(8) loads
in the new kernel information, it is deleted so in case the new kernel
hangs the machine, once it is rebooted, the machine will automatically
revert to its previous configuration.
The options are as follows:
-D Invoking nextboot with this option removes an existing
-f This option disables the sanity checking which checks if the
kernel really exists before writing the nextboot configura-
-k kernel This option specifies a kernel directory relative to /boot to
load the kernel and any modules from.
-o options This option allows the passing of kernel flags for the next
/boot/nextboot.conf The configuration file that the nextboot configura-
tion is written into.
To boot the GENERIC kernel with the nextboot command:
nextboot -k GENERIC
To enable into single user mode with the normal kernel:
nextboot -o "-s" -k kernel
To remove an existing nextboot configuration:
The original nextboot manual page first appeared in FreeBSD 2.2. It used
a very different interface to achieve similar results.
The current incarnation of nextboot appeared in FreeBSD 5.0.
This manual page was written by Gordon Tetlow <gordonATFreeBSD.org>.
The nextboot code is implemented in the loader(8). It is not the most
throughly tested code. It is also my first attempt to write in Forth.
Finally, it does some evil things like writing to the file system before
it has been checked. If it scrambles your file system, do not blame me.
BSD November 4, 2002 BSD