NEWLFS(8) BSD System Manager's Manual NEWLFS(8)
newlfs - construct a new LFS file system
newlfs -L [newlfs-options] special
Newlfs builds a log-structured file system on the specified special de-
vice basing its defaults on the information in the disk label. (Before
running newlfs the disk must be labeled using disklabel(8).)
The following options define the general layout policies.
-B The logical segment size of the file system in bytes.
The block size of the file system in bytes.
-L Create a log-structured file system (LFS). This flag is cur-
-m free space %
The percentage of space reserved from normal users; the mini-
mum free space threshold. The default value used is 10%.
See tunefs(8) for more details on how to set this option.
-s size The size of the file system in sectors.
disktab(5), fs(5), dumplfs(8), disklabel(8), diskpart(8), tunefs(8)
M. McKusick, W. Joy, S. Leffler, and R. Fabry, "A Fast File System for
UNIX,", ACM Transactions on Computer Systems 2, 3, pp 181-197, August
1984, (reprinted in the BSD System Manager's Manual).
The newlfs command appeared in 4.4BSD.
4.4BSD June 19, 1993 1