NETGROUP_MKDB(8) OpenBSD System Manager's Manual NETGROUP_MKDB(8)
netgroup_mkdb - generate the netgroup databases
netgroup_mkdb [-o database] [file]
netgroup_mkdb creates db(3) style databases for the specified file. If
no file is specified, /etc/netgroup is used. These databases are then
installed into /etc/netgroup.db. The file must be in the correct format
The options are as follows:
Put the output databases in the named file.
The databases are used by the C library netgroup routines (see
netgroup_mkdb exits zero on success, non-zero on failure.
/etc/netgroup.db current netgroup database
/etc/netgroup.db.tmp a temporary file
/etc/netgroup current netgroup file
db(3), getnetgrent(3), netgroup(5)
Because netgroup_mkdb guarantees not to install a partial destination
file it must build a temporary file in the same file system and if suc-
cessful use rename(2) to install over the destination file.
If netgroup_mkdb fails it will leave the previous version of the destina-
tion file intact.
OpenBSD 3.6 February 3, 1994 1